Stepping in Temperature channel

Hello, new user of Embergen here but not new to fluid simulations. I was wondering what is the solution to get rid of this ‘stepping’ that only appears in the flames channel (see attached screen grab). Is it a voxel size issue? Right now the voxels are at 0.030 m which is much lower than the default of 0.1 m. This only happens in the flames channel as the density is very clean. I am taking the exported VDB into Unreal Engine 5.4 (where the screen grab comes from). As a test I also tried the VDB in Redshift through C4D and the results are the same.

Thank you for any insights.

Hi Ricardo, thanks for letting us know about this. Can you send the EmberGen file you’re using? Does the stepping occur there as well? This looks like the type of artifacts you get with a very high force amplifier. Any additional details you can provide will be very helpful!

Hi and thank you for the reply. The aliasing/stepping is visible in Embergen but not as pronounced. I do believe my twist on the line force was pretty high. Who or where do I send the embergenfile to?

Thanks again!

You can send a link here or to our support email support@jangafx.com!

Thank you WIll. I sent the drop box link to that email address and said it was addressed to you.

great thanks, I replied to that email today!

Thank you Will. I did received an email which is just a screengrab of an Embergen window. Was there a note or explanation with it?

Oh there is a note. I couldn’t see it because it is white text on a white background so it was invisible. Found it by accident as I was trying to copy something from the email.

Hi again Will, the settings you screen grabbed and sent to me helped with the stepping. Especially in the volume object in Redshift. In UE5 it still visible but it’s better than it was.