Blocky artifacts in VDB (Seems to be a blender issue, not EmberGen)

Hi,

I’m now testing the software for usable. Everything is great. But I got some blocky artifacts in Blender. And I believe it’s not Blender fault, but EmberGen export. Anyone know about it, and maybe have a solution? Attaching image of the problem. It’s not on every frame, just randomly.

This may be due to an issue we’re facing where channels like temperature may be corrupted. Are you using upscaling by chance?

Otherwise could be a blender issue. One thing you could do is download one of our free VDBs: https://jangafx.com/software/embergen/download/free-vdb-animations/

Maybe the explosion and see if the issue persists. We know for a fact those VDB’s are good and if they work then it’s likely the corruption issue we’re trying to debug. If they break, then it’s likely your blender setup.

Due to the big chunks missing though, I’m leaning towards it being our corrupted VDBs

What version of the software are you on? 0.5.3.1 is the latest.

Hi Nick,

Thank You for answer.
Yes, I’m using up-scaling, so this will be the issue? Because from what I remember first test was without upscale, and I can’t recall blocky artifacts. Will test the VDB’s in the morning.

Also if I may ask here. How to properly export VDB to have the same placement as exported to EmberGen geometry? I got every time a different scale and placement.

We currently don’t have anything that guarantees mesh placement as meshes shrink to fit the bounds of the simulation (not ideal we know). We’ll need to add in more features to ensure that meshes line up properly in the near future once you export the VDBs.

As for the bug here, I definitely do think this is caused by our upscaling corruption bug then. We aren’t yet sure of the cause but we’re going to build a VDB inspector this week so that we can debug it more easily on our end. Do you know if this issue shows up in all exported VDB frames or if it’s only in some of them? This may help us narrow down the issue.

1 Like

I now try without upscaling, so NONE option, and it’s the same. Will investigate better later, need to to sleep now. The issue doesn’t show all the time there are good frames, also it aint a blocky “hole” in the same place. But sadly it aint the upscale issue. Without it looks the same. It also isn’t the cause of choosing the “temperature attribute” (in Blender shader) to fuel, or flames. I’m using flames.

1 Like

Ok, hmm. If it doesnt appear on non-upscaled, then i wonder if it’s a blender issue. Could be on our end though… can you let me know what version of the software you are on? Sending me the corrupted VDB frame could possibly help as well.

Thanks!

Ok I have new informations. Sadly, but need to confirm it, this is Blender bug, because in EEVEE engine it looks good, but in Cycles, the block “holes” appears. Need to investigate further, but I’m informing, so You know.

Excellent for us then. If you do indeed find it again in other renderers, let us know and we’ll have something else to go on :slight_smile:

Thanks for the report!

For You to monitor, confirmed Blender BUG:
https://developer.blender.org/T77882

1 Like

Excellent! Hopefully it gets fixed soon.