Particle emission cuts out when rendering

I’ve created a particle-based snow effect in embergen using the ‘Experimental particles’ feature.

It looks great in the render preview window - exactly what I want to render.

The problem is that when I actually export the frames as an image sequence, the particle emission just… stops a few hundred frames into a 1400frm render.

Steps tried:
-Changing the burst length
-Changing the emission rate and burst size
-Changing the particle pool size

It is extremely frustrating for the render preview to not accurately reflect the rendered output. Any idea what I’m doing wrong?

Hey there, sorry you’re having these issues. Can you screenshot the preview and render so that I can compare them?

As far as the render stopping a few hundred frames in, are you rendering locally? and what graphics card are you using? We’ve heard of a couple issues similar to this so I will look into the cause and see what solutions make sense to try out

Preview at f150:

Render at f150:

Rendering locally - tried on both a 2080ti, and a A6000-24G I have access to

I can provide the scene file if needed - but not post it publicly.
This IS, unfortunately, a dealbreaker for an upcoming project, so any help is appreciated.

Hi there, sorry for not responding sooner. Can you email the file to us at That’ll help in identifying what’s going wrong here. Thanks!