Importing animated fbx stuck on processing

Hello! I am trying to import an animated FBX from blender into embergen. The fbx is an animated character, with its armature. However when I load the fbx into embergen, the import node just keep processing, and even after waiting more than 10 minutes, nothing happens. The fbx is quite light (about 10mb) and it imports without any issue into other software.

I also tried exporting the fbx without animation, and it works, however it still takes a strangely long time to load into embergen and I cannot understand what’s the issue.

Here you can download the fbx to test… any idea what the issue might be?

Thank you!

Did you ever find a solution for this? having the same problem.

unfortunately not directly, meaning that the problem I am having with that FBX isn’t solved. On discord however one of the devs is looking into it.

Good news is that I didn’t know embergen now support alembic import. Instead of fbx I exported the same mesh in alembic and I was able to import it in embergen easily, so I would suggest you try that.

hey there, where are you importing this file from? it works fine on my end. when i import it into blender it looks like its just a camera with no animation, is that what it’s supposed to be?

Hi, thanks for checking! That’s because I am afraid I pasted the link to the wrong fbx :smiley: Sorry about that!

This is the one

Hey sorry for the delay, I’ve sent this mesh to the team and we’ll work on optimizing it for EmberGen

1 Like