(EmberGen) Seamless looping not working

After an upgrade to 0.5.6.1 simulation looping is affected by frames jump on the edges. Try to make a loop, then generate flipbook, then play the flipbook and notice there is no smooth looping.

Just chiming in to say the same thing. Not using upscaling, turbulence, or particles, but my loops are interrupted in the exported flipbook.

Do either @lbabieno or you @Andicraft Andi have any videos to show? Hard to diagnose without seeing the issue.

Same Issue for me on 0.5.6.3.

  1. Open preset: 064_looping_smoke_puff.ember (comes with the software)

  2. Notice the Looping Render works.
    LoopRender

  3. Select the Export Image node and hit Generate Flipbook(s)
    And you get:

  4. Notice Frame 1 and Frame 64 being way off… This flipbook,( Doug Marcaida’s voice ) will not loop.

Digging a bit deeper…

Correcting the timing control on the original preset was able to fix the issue. It’s likely just a bad preset… was my first feeling about it…
image

However, given a first frame of 128, a stride of 2, and 64 frames to export… I expect frames render to be between 128 and 256… but the log output says this:
image

So the export might be off / might still have a bug in there. Even if visually, things look ok. That log output is bugging me.

Same issue here. Simulation is looping perfectly in the viewport but on export, it is not. I am also missing my first frame for some reason…@Mederic noticed the same issue in the log, might be part of the issue…

You’ll miss your first frame if you aren’t starting on an even numbered frame, and your frame stride isn’t setup correctly.
Post a screenshot of your looping settings and I can tell you what’s wrong.


Let me know if something is wrong with my setup! Thanks Nick :slight_smile:

Make “130” be “129” since the first frame “80” is inclusive. 80 - 129 = 50 frames. Should fix the issues :slight_smile:

My first frame is now fixed :). Still, the animation is not looping on my spritesheet but it is in my viewport. It look like its rendering only the original simulation and not the ‘‘blending simulation’’ that loops.

bugloop

Found this issue… It seems like the looping does not support upscaling :(. If I remove it, its looping fine.

Indeed, upscaling, turbulence and particles cause loops to break.