Looping correctly in timeline but not in flipbook

I have a looping sequence and when I view it in the scene it loops fine but when I export a flipbook it no longer loops. Here is a gif showing the first and last frame of the flipbook:

I made sure that none of the “unsupported for looping” features are enabled and I am not using a custom mesh or anything.

Here is a link to the project in question.

Hi sorry for the late reply, but I’ve requested access to the file!

Heya, sorry for the late reply. I was out all last week.
I’ve granted access to the file.

Ahh okay, I don’t think I can properly explain why this is the case, but we’ve found that once you push the TimeStep past 100Hz, that’s when you start to see looping break off from deterministic exports. So with a TimeStep of 240, the remapping isn’t properly applied and it ends up not working. We’re aware of this and are planning on having it fixed for EmberGen 2.0

I kinda thought that might be the case so I tried setting the timestep back down to the default. It took some fiddling to get it looking similar but I managed it only to find that the loop still didn’t work in the exported flipbook.

And in both cases it’s ONLY in the flipbook. If you watch the effect in the viewport it loops perfectly in both cases.

It looks like I’m able to get it to loop, but you will need to readjust the loop bounds and export range. I know that it’s not intuitive that it loops in the Viewport but not in the actual export, but I’ve discussed this issue with the devs before and I can’t give the exact reason as to why, but it’s not as simple as it seems.