Exporting Alpha Channel (Issue #201) (FIXED)

I just started using/learning EmberGen tonight, and so far things have been great. Watched what there is for the tutorials so far, and have even started to get things pulled into Unity. However, I’ve suddenly run into an issue.

After making some changes to the color of my fire, and attempting to re-export the texture sheet, I am no longer able to export any alpha data. I have “export alpha” checked in the capture node, and in the export node I am exporting a full RGBA (component Mode) into a .tga, but when I have my final image, my alpha channel is just pure white.

When I use the preview mode in the viewport and attempt to see the alpha channel as well, I’m not seeing any data to output.

I’ll happily upload some images of nodes/settings, even the file itself, upon request, but at this point I’m too new to even know what would be useful!

Other then this little hiccup, I’m loving the software so far! It’s been a lot of fun to play around with and start to get familiar with!

Thanks for the help!

:Extra info:
I’ve also just tried loading up the default scene, and while this will show the alpha channel in the preview tab, it still fails to export anything other then a full white image for the alpha channel.

1 Like

Thanks, we’ll look into this to see if we can verify it. Are you only exporting your flames channel and nothing else? Flames alone do not have an alpha channel as it’s emissive.

It definitely could have something to do with this, I am attempting to export only fire. I was unaware that without smoke there would be no alpha data exported. Its strange though, I was able to export (what I thought was just fire) with an alpha channel when I first started. Maybe I accidentally did something sneaky where I had a tiny amount of smoke, so it generated the alpha, but the smoke was so thin it wasn’t visible?

Also of interest is that if I load up the default file (which has smoke) I can see the alpha channel being generated in the preview alpha viewport, but when I export the alpha is still left pure white.

The only thing I did in the default file was expose a “render combined” node, and hook it up to a RGBA export node.

I believe this has been solved in our latest update.