Embergen: Primitives in Alpha Channel?


How can I make sure the primitives I’m using as colliders in a scene end up in the alpha channel?

Even with colliders set to ‘visible’, they don’t turn up in the Alpha, I just get the fluid sim.

And can you please add ‘Alpha only’ as an option in the RGBA render options? Ace!


Here’s what I’m trying to do…

I’m using the tornado setup which suits this shot, and there are two side-by-side spheres which act as colliders to the upwards flow of the tornado…

I just need to be able to export the sim with the colliders as alpha opacity which I can extract and use to composite something where the spheres were.

A depth pass might help me here, but I’ve no idea how to use. it…what would I connect the min and max outputs to in the RGBA spectrum? I’ve used B channel with depth passes before, but not sure how to parse the two min/max options. Any advice much appreciated, I need the colliders to mask the fluid, until it breaches the spherical boundaries, then I need the opacity in an alpha to composite the final shot,

Any ideas how I might go about this?

Thanks a lot!


We currently don’t have an option to show colliders in a pass like what you’re asking for… but I can go ahead and add a task for us to look into so we can get it implemented in the future :slight_smile:

That would be great!

I got inspired to check out Redshift so I could play with the VDB’s, which has solved my immediate issue!