(EmberGen) crashes reproducible on VDB export (Fixed)

Hello, I clicked together a first simple simulation with the beta and I can get it to crash every time I try to export it to vdb. The crash occures at the first frame that should be exported, so it runs up to frame 54 (the start of the loop) and then EmberGen just vanishes without any error message.

The project file is here: https://www.dropbox.com/s/1nop24ard4wr1hn/embergen01.ember?dl=0

Hey. I checked out your included project file and its not crashing upon export on my end. All frames got exported properly, and the software kept running. So I think this will be kinda hard to debug.

Well, to be honest, it is not very encouraging to buy it, if a software crashes at first try. :wink:

More information:

Windows 10/64 on a Ryzen 3700X, two GTX 1080ti, latest Nvidia drivers, 32 GB mem, ASUS ROG Strix X570-F.

Are there any log files that I can provide you with to get to the problem?

I am quite interested in buying this software but not if it crashes immediately. I acknowledge, however, that this is a beta software so I’m willing to help with debugging. But “works here” is a bad support answer in any case.

Regards,
Xanathon

I’m just a random guy not a staff :wink: I just tried your files to see if I get the same error. This means that the devs will have hard time to reproduce it too.

I would appreciate if you leave that kind of decision to the devs.

Actual dev here, so I downloaded the file and it did indeed work in my latest build. My first guess is that you’re probably using a build that had some VDB export issues that we have since fixed. If you click Update Available in the main menu beside file and edit the software should update. Let us know if updating solves the issue, if it doesn’t, let us know and we can try and do a deeper dive into reproing this.

If for whatever reason you don’t see update available, then try running the wyupdate.exe within the installation folder to see if it picks up a new update. If it doesn’t then you’re on the latest version. 0.5.1.2

Hello Nick,

I downloaded and installed yesterday afternoon (CEST). There is no update button in the menu, but I can see the installed version number is 0.5.1 [0]. If I use wyUpdate.exe it says “Latest version already installed”.

I’m sorry to hear about your problems here. Unfortunately I am not able to reproduce it with the supplied project file. The thing that comes to mind is that it’s not able to write to the file and folder you’ve specified for some reasons. If you selected that path via the file dialog then that’d be weird. If you happened to type in the name and the folders like it is presented in the project file then it’ll probably fail since it does not know how to generate the folders for you yet. Regardless of whether that’s the case, this is a good reminder for us to make that part more robust, so thank you for that.

Other than that, a long shot is that if you run EmberGenBeta.exe from “cmd” it might give some error message that caused the crash.

I was able to write an earlier iteration to the same folder, so that cannot be the problem, and: yes, I selected the destination folder via the file dialog. It is a folder that already existed. Before saving the next vdb sequence I emptied the folder, so I think I can rule out a permission or “folder does not exist” problem.

I will try starting Embergen via commandline ans come back with results.

A logging system would be good for a future release …

1 Like

I’ve sent you an exectuable to try out if you don’t mind. Hopefully it might be a bit of use to help pinpoint this issue a little bit better.

Hi, I am having problems with export as well. I did update 12/05/2020. I have all latest GPU drivers installed. Link for the file is here: https://www.dropbox.com/s/slzpuktqmlhnhrr/portal.ember?dl=0
Problems I encounter:

  1. When I export density and velocity with upscale 2x, velocities in Houdini are broken. Showing up as a small box of random lines.
  2. Exporting with no upscaling works, just velocities are exported as 3 different volumes. Would be better to exported as a one vector field. Space wise it should be cheaper as well I guess. Or at least have that option.
  3. When I want to export just velocity EmberGen crashes when gets to first frame that should be exported.

Thank you guys. Awesome work. Love your software.

I have downloaded the project and WAS able to reproduce your error.
I was not able to solve it…
It played fine in the software and looked normal and exported normal as a VDB.

My issue was when I brought it into c4d (was using redshift- didnt try in octane as I used a known working embergenVDB set up. It just stops at frame 54. Its like a clipping issue but when i went back and re exported with double the bounds it looked the same. Stops is not the right statement, it clips and the bottom keeps playing but what would be produced after frame 54 on top is completely invisible.

No idea why. This is the only file that ever did that and this week ive made over a dozen project…Xanathon man I feel ya - this stuff is great when you getting working but just be patient as its a small team and many things to dial in!

Have you since tried to remake the bomb in a new file? is this happening to all your exports? Hope one of us can narrow it down - not sure if my info is helpful at all but I gave it a shot. (no update button on my window either - up to date version)

Hello, I had the same issue exporting VDBs on my machine and, after trying a lot of different settings and workarounds I got it working by changing my export folder’s name. mine had a french word with a special letter / character : “é”. After i renamed it without this letter it worked ! Maybe this is a problem with all special letters ? hope this might help someone.
Congrats to the devs on this amazing piece of software :slight_smile:

I also realized that for the same reasons (a folder with a “é” or other special letter in the export adress), png sequence would fail exporting but without crashing the software.

We have a fix coming out soon for the VDB crashes.

1 Like